Warning: count(): Parameter must be an array or an object that implements Countable in /var/www/html/wp-includes/post-template.php on line 284

Warning: count(): Parameter must be an array or an object that implements Countable in /var/www/html/wp-includes/post-template.php on line 284

Warning: count(): Parameter must be an array or an object that implements Countable in /var/www/html/wp-includes/post-template.php on line 284

Warning: count(): Parameter must be an array or an object that implements Countable in /var/www/html/wp-includes/post-template.php on line 284

解决Ubuntu 14.04无法安装wine的问题

想在机器上安装wine。

显示

如上提示应该是软件包存在依赖冲突。

按照网上的说法增加i386的软件包支持:

未果,依然unmet dependencies。于是使用aptitude解决冲突。

提示libcgmanager存在版本冲突,看上去是ubuntu本身的版本太高,wine依赖的版本太低导致。

于是降级libcgmanager。

重新安装wine,问题解决。

 

参考:

  1. https://askubuntu.com/questions/707333/how-to-debug-an-unmet-dependencies-problem
  2. https://www.reddit.com/r/linux4noobs/comments/2y1r58/cant_install_wine_on_ubuntu_1404/

 

 

chu's box · 浙ICP备14006917号